In network.h struct pollsd should be renamed struct pollfd to preserve compatibility/portability between ogc's socket net_poll() code and posix poll() code.
I could be even more wrong in saying this, but the struct should look like this...
struct pollfd {
s32 fd; /* Rename from 'socket' to 'fd' to maintain portability */
s32 events;
s32 revents;
};
Granted, with a couple #defines and cast when calling net_poll there is no real problem, but its seems odd that the rest of the network code is so similar to other implementations, bar this one struct.
[libogc] network.h - change name of structure
Who is online
Users browsing this forum: Ahrefs [Bot] and 3 guests