[libogc] network.h - change name of structure

Post Reply
DrTwox
Posts: 9
Joined: Thu Aug 21, 2008 10:41 am

[libogc] network.h - change name of structure

Post by DrTwox » Thu Jul 02, 2009 6:15 am

In network.h struct pollsd should be renamed struct pollfd to preserve compatibility/portability between ogc's socket net_poll() code and posix poll() code.

I could be even more wrong in saying this, but the struct should look like this...

struct pollfd {
s32 fd; /* Rename from 'socket' to 'fd' to maintain portability */
s32 events;
s32 revents;
};

Granted, with a couple #defines and cast when calling net_poll there is no real problem, but its seems odd that the rest of the network code is so similar to other implementations, bar this one struct.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests